Install Problem

Nov 17, 2008 at 3:09 PM

Before appear the error that i report in the last Discussion first it appears this when i try to procced:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'CSP.CRM.Deployment, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
File name: 'CSP.CRM.Deployment, Version=, Culture=neutral, PublicKeyToken=null'
   at CSP.Package.Controls.CRMCustomizations.ValidateCrmConnection()
   at CSP.Package.Controls.CRMCustomizations.btnTestConnection_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

=== Pre-bind state information ===
LOG: User = LITWAREINC\administrator
LOG: DisplayName = CSP.CRM.Deployment, Version=, Culture=neutral, PublicKeyToken=null
LOG: Appbase = file:///C:/Documents and Settings/Administrator/Desktop/CSP_Portal_Template/CSP Installers/
LOG: Initial PrivatePath = NULL
Calling assembly : CSP.Package, Version=, Culture=neutral, PublicKeyToken=null.
LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: The same bind was seen before, and was failed with hr = 0x80070002.


************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Documents%20and%20Settings/Administrator/Desktop/CSP_Portal_Template/CSP%20Installers/CSP.Package.exe
    Assembly Version:
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/
    Assembly Version:
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/
    Assembly Version:
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

    < jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Nov 21, 2008 at 8:08 AM
Try to copy CSP.CRM.Deployment.dll in the same path of CSP.Package.exe, it worked with me (now I've some problems with the connection test but it's another task ;) )
Nov 21, 2008 at 11:05 AM
Thank for you r post and your help do you have any ideia how to resolve the next step conection problem?

Nov 21, 2008 at 11:49 AM
Unfortunately i don't have any idea...  :(
I don't know if it's an auth error, a wrong path error or else...
Nov 21, 2008 at 11:59 AM
When you configure the internet portal and the intranet portal did you put tha login with administrator?
Maybe is a permission problem.
But i'm not sure.
It's just an ideia
I'm very interested in installing CSP but as in dinamycs integration as without it i have problems and i never get to the final step.
Nov 21, 2008 at 1:09 PM
I tried with administrator and another with admin permissions (both with a crm record and the right roles), but with the same results... Maybe a firewall issue? I don't know...
Nov 21, 2008 at 1:45 PM
My firwall is off so it can´t be!

2008/11/21 AleCs <>

From: AleCs

I tried with administrator and another with admin permissions (both with a crm record and the right roles), but with the same results... Maybe a firewall issue? I don't know...

Read the full discussion online.

To add a post to this discussion, reply to this email (

To start a new discussion for this project, email

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at

Nov 24, 2008 at 11:44 AM

There's something strange here: reading the installer's source code I found the function "TestConnection", so i wrote a simple c# program to test this function (just a simple ctrl-c ctrl-v...) and... the connection works!!!

Now the question is: why the SAME CODE works in my app and not in the installer?

Nov 24, 2008 at 11:56 AM
Hello, Nuno

As the header of the exception suggests

System.IO.FileNotFoundException: Could not load file or assembly 'CSP.CRM.Deployment

it looks like the installeris not finding the assembly code for the CRM installer part, so try to make sure that you haven't changed the directory structure of the installer package.


CSP Team
Dec 4, 2008 at 12:45 PM
Hello, Nuno

We have just posted a patch that fixes a couple of issues around the installer of the CRM Customizations. Please have a look at it here or in the Releases tab.