Problem with permissions generation?

Nov 18, 2008 at 4:24 PM
Edited Nov 18, 2008 at 4:25 PM

I’m interested in your project “Agenda Management” in order to localize it in French. First, I decided to test your solution without modification. I’ve used the Release version and deploy it on two different servers:

  • Server2008 (FR version) with MOSS2007 SP1, VS 2008
  • Server2003 (EN version) with MOSS2007, VS 2005 & 2008

In both installations, no error appeared while deploying.

I follow your User Guide to try the solution. I managed to create a Meeting Event. The calendar displays my event. I’m able to access to the new Meeting site. I managed to upload and approve a document in the site too.

But when I started the “Proposal Voting” workflow, this one is automatically ended. No user task was created.

Before I posted my message here, I tried to understand why and may find something. No permission is given to my users on the meeting site. I assume my users are in groups used by the meeting event creator. A list of items is generated containing users with their meeting function but no permission is given excepted to the system account.

Any ideas?

In other way, I tried to start to edit source code but, projects are signed and required password. Replace certificates by mine was difficult. There are many entries in different configuration files refer to them. But anyway, when I tried to generate solution, it gives me some errors, especially one. It seems the references, in the different projects, cause a circular reference on the solution, which blocks generation.

Am I wrong on something?

Dec 4, 2008 at 10:40 AM
Hi pfudala,

Usually when the "Proposal Voting" workflow is automatically ended is a sympton that it can't find users to assign the tasks.
Check if you have the following sharepoint groups:

  • Mayors
  • Approvers
  • Legal Advisers
  • Participants
  • Secretaries

You need to have at least 1 one user for each group. Mind that, the users added to those groups will only be used when you schedule a new meeting.

About the password to sign the assemblies, it's "cspcavedigital".

Hope it helps.

Best regards,

CSP Team

Dec 5, 2008 at 8:22 AM
Hi and thanks for your answers.

I really had users in those SharePoint groups.
When I schedule a new meeting, the SharePoint list of participants is created too. But "Users and groups" settings of the new meeting site do not contain any entries, even not inheritance of your SharePoint groups (mayors,...).

I'm going to try the way of a new generation of your source, using the password.

Waiting for any others suggestions.


Dec 5, 2008 at 11:15 AM

In your original post ( you mentioned that you installed the solution on MOSS FR and EN.
When installed on MOSS instances with a language that has not been localized on the solution, you may encounter issues related to permissions groups, etc, because all the names of that objects have diferent names according to locale.

Do you have the same behavior on both languages, or just on the FR installation ?

Best regards,

CSP Team

Dec 8, 2008 at 8:11 AM
Indeed, I tried the installation on both languages because I knew this type of problem on others projects and I had the same behavior.

In my original post, I mentioned that there is a circular reference between some of your assemblies. Is it normal?
Dec 9, 2008 at 6:24 PM
The circular reference it's not normal at all. The sources and bins that are available for download were tested with MOSS in different languages, with no circular reference issues...

Can you explain step-by-step what was the process of your installation and perhaps some printscreens of the errors you're having ?


CSP Team
Feb 24, 2009 at 1:17 PM

Hi dpereira,

I’ve been really busy for a long time, never enough time to redo the installation and make some printscreens.

In order to send you printscreens more easily, someone from Microsoft France has given me an email address of one of your colleagues, pserrano.

The installation that I explained in my email creates meeting sites without any permission. So, meeting sites are unusable.

Could you please ask my email to your colleague and see if I made something wrong in the process?

Thanks in advance.

Awaiting your reply,


Mar 6, 2009 at 11:16 AM

I pfudala,


According to the email with the detailed steps of the meeting creation process, I really can’t find anything wrong.

Since the participants are being added to the meeting participants list, it means that they are being located on the groups.


Have you checked, after the meeting creation process, if there’s new event log entries with errors ?


If there’s no log entries, my suggestion is that you attach a debugger to the Event Handler that creates the meeting site in order to find the issue that’s preventing that the correct permissions are added to the meeting site.


Best regards,

CSP Team

May 7, 2009 at 10:45 AM
Ok, about the password to sign the assembies, it was not "cspcavedigital" but "cavedigitalcsp" :-)
As soon as possible, I run a debug on the solution and tell you about the result.