New CRM VPC post installation issues

May 30, 2009 at 4:19 AM


I have installed the CSP Citizen platform to the latest CRM VPC (April 2009) and the installation is completed.  When browsing the new csp intranet sites, no web-parts are showing.  When trying to create a new csp membership login, it seems could not get to the membership database.  All sites created are using Network Services.  Tried to look into eventlog, limited information.  Any idea?  Anyone have try to install and test the solution with the latest CRM VPC?

On the deployment guide, it asked me to add an existing domain user cspintsite to CRM database, I could not find it.  so created 1, not sure what Domain previlleges does the user required.  And is there anything else I need to do to enable this newly created user interacte with the CSP sites?

Many thanks!


May 31, 2009 at 9:56 AM


you should look into the Sharepoint logs (12/LOGS) what is going on. Just one question, is this machine a Domain Controller? If so, you need to perform some operations to give the Network Service some user permissions. Is it your current situation?

CSP team

Jun 1, 2009 at 4:46 PM

Yes, the machine is also a domain controller and I had EventID 10016 in the system log.  The error message is "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {GUID} to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). etc.  Yes, it is using NETWORK SERVICE to run all the services.  What other things I need to change for it to run on a 1 server demo? 

Jun 1, 2009 at 7:20 PM


Just want to let you know that I have finally managed to get the sample code installed to the latest CRM VPC.  So I am really happy now!  Thanks for your help. 

In fact, I have attempted the installation a few times, most of the errors were related to NETWORK SERVICE account premission and DNS configuration issue.  At the end, I used the Contoso\Administrator account for everything and created a new web-site with different port number, no host header for all.  It worked well.  Also, I waited for a few minutes before copy and paste the web config xml.  The first time, I copied it too fast and the connectionstring was something like {0}, then I saw the connectionstring changed to CRM-SRV-01 after a few minutes.  At first, I though I was a bit tried and did not read the instructions well.  But the final installation instruction actually updated itself after a few minutes.  The first piece of xml needs to be placed after the configsections or Sharepoint will error out, etc.